PHPUnitManual:9.3

From 흡혈양파의 번역工房
Jump to: navigation, search
9.3 @requires 를 사용한 테스트의 생략

위의 메소드와 별개로, @requires 선언을 사용하여 공통적인 사전 조건을 기술할 수 있습니다.

표9.3 @requires 사용 예


예9.3 @requires 를 사용한 테스트 케이스의 생략

<?php
/**
 * @requires extension mysqli
 */
class DatabaseTest extends PHPUnit_Framework_TestCase
{
    /**
     * @requires PHP 5.3
     */
    public function testConnection()
    {
        // 이 테스트는 mysqli 확장 모듈과 PHP >= 5.3 이상이 필요합니다
    }
 
    // ... 이 외의 모든 테스트에는 mysqli 확장 모듈이 필요합니다
}
?>


특정 버젼의 PHP 를 요구하는 구문을 사용할 경우, "test suite" 에 있는 방법처럼 XML 설정 파일을 이용하여 버젼에 의존하는 include 의 사용을 검토하세요.


Notes